<button id="9slfp"><object id="9slfp"></object></button>
<button id="9slfp"><object id="9slfp"><menuitem id="9slfp"></menuitem></object></button>
    <em id="9slfp"></em>
    <button id="9slfp"><acronym id="9slfp"><input id="9slfp"></input></acronym></button>
  • 免費開源的iOS開發學習平臺

    CocoaPods:2-使用CocoaPods安裝SDK

    CocoaPods安裝完畢后,我們就可以通過CocoaPods來安裝第三方庫了。使用CocoaPods為一個工程安裝第三方庫,需要按照如下步驟進行。

    使用CocoaPods安裝SDK

    在工程目錄中,創建Podfile文件。使用終端命令行工具,在工程所在的目錄,添加一個名稱為Podfile的空文件。使用的命令如下:

    $ touch Podfile
    

    使用vim命令編輯Podfile,在Podfile中添加需要安裝的第三方庫名稱,我們以添加一個名為AMap3DMap的庫以及一個名為AMapLocation的庫為例,使用:wq保存文件內容。

    platform :ios, '7.0' #手機的系統
    target 'Location' do #工程名字
         pod 'AMap3DMap'  #3D地圖 SDK
         pod 'AMapLocation' #定位SDK
    end
    

    當我們需要為多個Target導入不同的庫時,也可以在Podfile中針對不同的Target做不同的設置。

    執行下列命令進行配置并安裝第三方庫.

    pod repo update  
    pod install
    

    安裝命令執行成功后,在工程目錄中,會生成.xcworkspace 文件,打開.xcworkspace 文件以啟動工程,原.xcodeproj文件不再使用。

    使用CocoaPods升級SDK

    若希望升級已安裝的第三方庫到最新版本,可以在Podfile文件的目錄中執行如下命令:

    pod repo update 
    pod update
    

    指定SDK的版本

    使用指定版本 SDK,需要修改 Podfile 文件,添加版本相關信息,其文件內容如下:

    platform :ios, '7.0' 
    target 'Location' do  
       pod 'AMap3DMap', '~>4.4.1' #此處指定版本號
    end
    

    然后再執行如下命令:

    pod repo update
    pod install
    

    精品h动漫无遮挡在线看中文|久久精品国产精品亚洲艾草|久久亚洲春色中文字幕|精品人妻少妇一区二区三区|欧美精品v国产精品v

    <button id="9slfp"><object id="9slfp"></object></button>
    <button id="9slfp"><object id="9slfp"><menuitem id="9slfp"></menuitem></object></button>
    <em id="9slfp"></em>
    <button id="9slfp"><acronym id="9slfp"><input id="9slfp"></input></acronym></button>